What is CVE-2022-2068?A high-severity flaw in OpenSSL, explained.
CVE-2022-2068 is a high-severity flaw (CVSS 7.3) in OpenSSL, published on 21 June 2022. It is not on the list of flaws known to be exploited today. The latest forecast puts its chance of use in the next 30 days at 96%. If you run an affected version, plan in the vendor’s fix.
Published 21 June 2022. Record last updated 3 November 2025. We keep this page's data up to date.
What is CVE-2022-2068? In plain terms.
An attacker has to be already on the device with an ordinary user account, but a person has to take an action first. If it works, the attacker can read data, change data and take it offline.
In addition to the c_rehash shell command injection identified in CVE-2022-1292, further circumstances where the c_rehash script does not properly sanitise shell metacharacters to prevent command injection were found by code review. When the CVE-2022-1292 was fixed it was not discovered that there are other places in the script where the file names of certificates being hashed were possibly passed to a command executed through the shell. This script is distributed by some operating systems in a manner where it is automatically executed. On such operating systems, an attacker could execute arbitrary commands with the privileges of the script. Use of the c_rehash script is considered obsolete and should be replaced by the OpenSSL rehash command line tool. Fixed in OpenSSL 3.0.4 (Affected 3.0.0,3.0.1,3.0.2,3.0.3). Fixed in OpenSSL 1.1.1p (Affected 1.1.1-1.1.1o). Fixed in OpenSSL 1.0.2zf (Affected 1.0.2-1.0.2ze).
What kind of flaw is it?
- CWE-78Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')
How an attack on it works
Read straight from its severity rating, translated out of the shorthand.
- Where an attacker can beAlready on the device
- How hard it is to pull offEasy: no special conditions
- Login needed firstAn ordinary user account
- Does someone have to clickYes, a person has to take an action
- What an attacker getsCan read data, change data and take it offline
Severity vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Is CVE-2022-2068 being exploited? Not that we know of.
It is not on the list of flaws known to be exploited today. The latest forecast puts the chance of it being used in the next 30 days at 96%. That can change at any time, which is why we keep watching.
Timeline
- Published
- Exploit likelihood fell
- Exploit likelihood jumped
- Record last updated
CVE-2022-2068 scores 86. Action: Patch immediately.
We keep the score of every published flaw up to date as the evidence changes. Four things go into the score, and evidence that criminals are actually using it counts most. In order:
- Evidence it is being exploitedBiggest factor
- How severe it isStrong factor
- How widely exposed it isKey context
- Real threat activity around itKey context
85 and above is Critical. Anything confirmed as exploited is always marked for an emergency patch, whatever its score.
When CVE-2022-2068 matches software you track, it lands in your list with its score and the reasons behind it.
See your own ranked list →Who is affected by CVE-2022-2068? 28 products.
The published record lists 28 products from 6 vendors. Versions are shown as published: "1.0.2 to before 1.0.2zf" means from 1.0.2 up to, but not including, 1.0.2zf. If you run one of these, check your version, then go to the fix below.
- Application
OpenSSL
by OpenSSL
Affected versions1.0.2 to before 1.0.2zf1.1.1 to before 1.1.1p3.0.0 to before 3.0.4 - Application
Sinec Ins
by Siemens
Affected versionsbefore 1.01.01.0-sp11.0-sp2 - Operating system
Debian Linux
by Debian
Affected versions10.011.0 - Operating system
Fedora
Affected versions3536 - Operating system
Aff 8300 Firmware
by Netapp
Affected versionsversion not specified - Operating system
Aff 8700 Firmware
by Netapp
Affected versionsversion not specified - Operating system
Aff A400 Firmware
by Netapp
Affected versionsversion not specified - Operating system
Bootstrap OS
by Netapp
Affected versionsversion not specified - Application
Element Software
by Netapp
Affected versionsversion not specified
How do I fix CVE-2022-2068? Four steps.
- Check whether you run itCompare your versions with the affected products above. Not sure what you run? EdgeProtect can work it out from your public website, or you can pick it from a list.
- Apply the vendor’s fixInstall the update named in the vendor’s advisory. We’ve put the advisories and patch notes first in the list.
- If you can’t patch todayFollow any mitigation the vendor publishes, and limit who can reach the affected system from the internet until the update is in.
- Keep an eye on itTrack the product and we tell you as soon as we spot this flaw on the list of exploited flaws, or a jump in its exploit likelihood.
Does CVE-2022-2068 affect you? We'll keep checking.
Looking flaws up one at a time doesn't scale. Tell us what you run once, and we tell you which flaws matter to you, in what order, and keep watching for new ones.
- Tell us what you runPick your software from a list, or let us work it out from your website.
- We match it to every flawOver 400,000 published flaws, checked against your list.
- Ranked by real-world riskA 0 to 100 score, led by evidence criminals are using it.
- Told as soon as we knowAn alert by email, in the app or by webhook to your own tools.
Free plan, no card needed. Nothing to install.
1 new flaw affects software Acme tracks
In addition to the c_rehash shell command injection identified in CVE-2022-1292, further circumstances where the c_rehash script does not properly sanitise s...
- Matched to
- OpenSSL on Acme's software list
- What to do
- Plan in the vendor’s update
Sent to the alert recipients Acme chose. Also in the app and to Acme's webhook.
CVE-2022-2068 is a high-severity flaw in OpenSSL, published on 21 June 2022. An attacker has to be already on the device with an ordinary user account, but a person has to take an action first. If it works, the attacker can read data, change data and take it offline.
It scores 7.3 out of 10 on the CVSS severity scale, which is high. Our risk score for CVE-2022-2068 is 86 out of 100, which is Critical. Its action is "Patch immediately". Not confirmed as exploited yet, but serious or likely enough that it should not wait for a quiet month.
It is not on the list of flaws known to be exploited today. The latest forecast puts the chance of it being used in the next 30 days at 96%. That can change at any time, which is why we keep watching.
For OpenSSL: 1.0.2 to before 1.0.2zf, 1.1.1 to before 1.1.1p, 3.0.0 to before 3.0.4. The record lists 28 products in all, each with its versions, under "Who is affected" on this page.
Install the update the vendor names in its advisory, linked first under "How do I fix" on this page. If you can't patch today, follow the vendor's mitigation and limit who can reach the affected system from the internet.