Dolphinscheduler vulnerabilitiesRanked by how likely they are to be used.
Dolphinscheduler is made by Apache. We track 24 published vulnerabilities in it, across 47 versions. None of them is on the list of flaws known to be exploited today. If you run Dolphinscheduler, keep it on a version the vendor still supports.
We keep watching the known-exploited list.
Which Dolphinscheduler vulnerabilities are being exploited?
This is the list that matters most: flaws criminals are using now.
None of Dolphinscheduler's published vulnerabilities is on the list of flaws known to be exploited today. We keep watching that list.
Which Dolphinscheduler flaws are most likely to be used?
Ranked by the latest exploit-likelihood forecast: the chance each flaw is used in an attack in the next 30 days. A high severity score on its own doesn't tell you that. Flaws shared by many other makers' products are left out.
- 8.1%CVE-2020-11974Critical
In DolphinScheduler 1.2.0 and 1.2.1, with mysql connectorj a remote code execution vulnerability exists when choosing mysql as database.
- 6.0%CVE-2024-30188High
File read and write vulnerability in Apache DolphinScheduler , authenticated users can illegally access additional resource files.
- 2.8%CVE-2022-45462Critical
Alarm instance management has command injection when there is a specific command configured.
- 2.7%CVE-2022-45875Critical
Improper validation of script alert plugin parameters in Apache DolphinScheduler to avoid remote command execution vulnerability.
- 2.3%CVE-2023-49109Critical
Exposure of Remote Code Execution in Apache Dolphinscheduler.
- 2.1%CVE-2024-43202Critical
Exposure of Remote Code Execution in Apache Dolphinscheduler.
- 2.0%CVE-2022-25598High
Apache DolphinScheduler user registration is vulnerable to Regular express Denial of Service (ReDoS) attacks, Apache DolphinScheduler users should upgrade to version 2.0.5 or higher.
- 1.9%CVE-2021-27644High
In Apache DolphinScheduler before 1.3.6 versions, authorized users can use SQL injection in the data source center.
- 1.8%CVE-2022-26884Medium
Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.
- 1.8%CVE-2020-13922Medium
Versions of Apache DolphinScheduler prior to 1.3.2 allowed an ordinary user under any tenant to override another users password through the API interface.
Running Dolphinscheduler? We'll keep checking.
Looking flaws up one at a time doesn't scale. Tell us what you run once, and we tell you which flaws matter to you, in what order, and keep watching for new ones.
- Tell us what you runPick your software from a list, or let us work it out from your website.
- We match it to every flawOver 400,000 published flaws, checked against your list.
- Ranked by real-world riskA 0 to 100 score, led by evidence criminals are using it.
- Told as soon as we knowAn alert by email, in the app or by webhook to your own tools.
Free plan, no card needed. Nothing to install.
1 new flaw affects software Acme tracks
In DolphinScheduler 1.2.0 and 1.2.1, with mysql connectorj a remote code execution vulnerability exists when choosing mysql as database.
- Matched to
- Dolphinscheduler on Acme's software list
- What to do
- Plan in the vendor’s update
Sent to the alert recipients Acme chose. Also in the app and to Acme's webhook.
We track 24 published vulnerabilities listed under the name Dolphinscheduler, across 47 versions.
None of Dolphinscheduler's vulnerabilities is on the list of flaws known to be exploited today.
Create a EdgeProtect account and track Dolphinscheduler. We match it against every published flaw, give each one a risk score from 0 to 100 and keep watching, so you hear about new ones as soon as we know, by email, in the app or by webhook.