[{"data":1,"prerenderedAt":-1},["ShallowReactive",2],{"$f0f4Sgon0_tvtDs4zfbKTfWClXFZG1UrNpAiAZhy-zto":3},{"success":4,"data":5},true,{"vendor":6,"topVulnerabilitiesByEpss":18,"kevVulnerabilities":59,"topProductsByCves":65,"seoMetadata":67,"meta":76},{"vendorId":7,"vendorName":8,"productCount":9,"cveCount":10,"kevCount":9,"versionCount":11,"lastCveUpdate":12,"firstLetter":13,"products":14,"description":17},680,"adminer",1,6,81,"2025-08-25","a",[15],{"id":16,"product_name":8,"version_count":11,"cve_count":10,"kev_count":9,"last_cve_update":12},2030,"Adminer is a technology vendor with 1 tracked product and 6 known security vulnerabilities. Get comprehensive security analysis, vulnerability tracking, and threat intelligence for this vendor.",[19,27,34,41,49,54],{"cveId":20,"description":21,"publishedDate":22,"cvssScore":23,"cvssVersion":24,"severity":25,"isKev":4,"epssScore":26},"CVE-2021-21311","Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.","2021-02-11",7.2,"v3.1","High",0.98464,{"cveId":28,"description":29,"publishedDate":30,"cvssScore":31,"cvssVersion":24,"severity":25,"isKev":32,"epssScore":33},"CVE-2021-43008","Improper Access Control in Adminer versions 1.12.0 to 4.6.2 (fixed in version 4.6.3) allows an attacker to achieve Arbitrary File Read on the remote server by requesting the Adminer to connect to a remote MySQL database.","2022-04-05",7.5,false,0.13641,{"cveId":35,"description":36,"publishedDate":37,"cvssScore":38,"cvssVersion":24,"severity":39,"isKev":32,"epssScore":40},"CVE-2021-29625","Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).","2021-05-19",6.1,"Medium",0.09572,{"cveId":42,"description":43,"publishedDate":44,"cvssScore":45,"cvssVersion":46,"severity":47,"isKev":32,"epssScore":48},"CVE-2018-7667","Adminer through 4.3.1 has SSRF via the server parameter.","2018-03-05",9.8,"v3.0","Critical",0.04977,{"cveId":50,"description":51,"publishedDate":52,"cvssScore":38,"cvssVersion":24,"severity":39,"isKev":32,"epssScore":53},"CVE-2020-35572","Adminer through 4.7.8 allows XSS via the history parameter to the default URI.","2021-02-09",0.02003,{"cveId":55,"description":56,"publishedDate":12,"cvssScore":57,"cvssVersion":24,"severity":25,"isKev":32,"epssScore":58},"CVE-2025-43960","Adminer 4.8.1, when using Monolog for logging, allows a Denial of Service (memory consumption) via a crafted serialized payload (e.g., using s:1000000000), leading to a PHP Object Injection issue. Remote, unauthenticated attackers can trigger this by sending a malicious serialized object, which forces excessive memory usage, rendering Adminer’s interface unresponsive and causing a server-level DoS. While the server may recover after several minutes, multiple simultaneous requests can cause a complete crash requiring manual intervention.",8.6,0.00735,[60],{"cveId":20,"description":21,"publishedDate":22,"cvssScore":23,"cvssVersion":24,"severity":25,"isKev":4,"epssScore":26,"cisaVulnName":61,"cisaDateAdded":62,"cisaShortDescription":63,"cisaRequiredAction":64},"Adminer Server-Side Request Forgery Vulnerability","2025-09-29","Adminer contains a server-side request forgery vulnerability that, when exploited, allows a remote attacker to obtain potentially sensitive information.","Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.",[66],{"id":16,"product_name":8,"version_count":11,"cve_count":10,"kev_count":9,"last_cve_update":12},{"title":68,"metaDescription":69,"keywords":70,"structuredData":71},"Adminer - Security Vulnerabilities & Analysis | EdgeProtect","Comprehensive security analysis for Adminer covering 1 product with 6 tracked vulnerabilities including 0 critical and 1 high-severity issues and 1 CISA KEV vulnerability. Real-time threat intelligence, CVE tracking, and security recommendations.","Adminer vulnerabilities, Adminer security, Adminer CVE, Adminer threat intelligence, vendor security analysis, cybersecurity threats, vulnerability management, CVE tracking, Adminer KEV, Adminer exploited vulnerabilities",{"@context":72,"@type":73,"name":74,"description":69,"url":75},"https:\u002F\u002Fschema.org","Organization","Adminer","https:\u002F\u002Fedgeprotect.io\u002Fvendors\u002Fadminer",{"totalProducts":9,"totalVulnerabilities":10,"kevVulnerabilities":9,"lastUpdated":12,"generatedAt":77,"apiVersion":78},"2026-10-28T18:19:23.758Z","3.0"]